Discussion:
Afficher les zeros
(trop ancien pour répondre)
Brat'ac
2017-02-16 11:37:17 UTC
Permalink
Raw Message
Bonjour,

dans le classeur les zéros ne sont pas affichés dans les cellules, mais
j'aimerais bien que dans les
cellules qui ont un format en euros celle-ci affichent quand même
00,00€

J'ai essayé de créer un format sans résultat

Merci
Jacquouille
2017-02-16 15:28:23 UTC
Permalink
Raw Message
Bonjour

Dans mon vieux 2003 .....

Menu / Outils / Options / Affichage / Cocher Valeurs zéros.

Mais ne s'affichent les zéros que s'ils sont issus d'une formule ou
introduits au clavier.

Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Brat'ac" a écrit dans le message de groupe de discussion :
***@yopmail.com...

Bonjour,

dans le classeur les zéros ne sont pas affichés dans les cellules, mais
j'aimerais bien que dans les
cellules qui ont un format en euros celle-ci affichent quand même
00,00€

J'ai essayé de créer un format sans résultat

Merci


---
L'absence de virus dans ce courrier électronique a été vérifiée par le logiciel antivirus Avast.
https://www.avast.com/antivirus
MichD
2017-02-16 15:49:35 UTC
Permalink
Raw Message
Bonjour,

Créer un format personnalisé et tu l'appliques à toute
la plage de cellules contenant des informations monétaires.

Un exemple de format : # ##0,00 $ ;-# ##0,00 $ ;- $ ;@
Posifit; Négatif : Valeur nulle; texte

Tu dois aussi activer (si désactiver) l'option suivante dans les options régionales / Afficher
les options pour cette feuille de calcul : "Afficher un zéro dans les cellules qui ont une
valeur zéro.

Pour que ce format soit disponible dans tout le classeur, ce serait plus facile de créer un
"STYLE" avec ce format de cellule et affecter les plages de cellules désignées de ce format.


MichD


"Brat'ac" a écrit dans le message de groupe de discussion :
***@yopmail.com...

Bonjour,

dans le classeur les zéros ne sont pas affichés dans les cellules, mais
j'aimerais bien que dans les
cellules qui ont un format en euros celle-ci affichent quand même
00,00€

J'ai essayé de créer un format sans résultat

Merci
Brat'ac
2017-02-16 19:10:09 UTC
Permalink
Raw Message
Post by Brat'ac
Bonjour,
Créer un format personnalisé et tu l'appliques à toute
la plage de cellules contenant des informations monétaires.
Posifit; Négatif : Valeur nulle; texte
Tu dois aussi activer (si désactiver) l'option suivante dans les options
régionales / Afficher les options pour cette feuille de calcul : "Afficher un
zéro dans les cellules qui ont une valeur zéro.
Merci du retour,
Dans la cellule j'ai "-$" si = 0 et 0,01$ à la place de 8,00€
MichD
2017-02-16 21:42:50 UTC
Permalink
Raw Message
Place sur cjoint.com ton fichier et retourne-nous ici l'adresse. Je n'ai pas besoin de tout son
contenu, seulement un exemple démontrant ce que tu as énoncé au niveau des résultats obtenus.
N'oublie pas dans chaque cas de dire quel est l'affichage que tu désires obtenir.

MichD
MichD
2017-02-17 01:49:00 UTC
Permalink
Raw Message
Si tu veux afficher le 0 quand tu tapes 0 dans une cellule :
Modifie le format comme ceci :# ##0,00 $ ;-# ##0,00 $ 0 $ ;@

MichD
Post by Brat'ac
Bonjour,
Créer un format personnalisé et tu l'appliques à toute
la plage de cellules contenant des informations monétaires.
Posifit; Négatif : Valeur nulle; texte
Tu dois aussi activer (si désactiver) l'option suivante dans les options régionales /
Afficher les options pour cette feuille de calcul : "Afficher un zéro dans les cellules qui
ont une valeur zéro.
Merci du retour,
Dans la cellule j'ai "-$" si = 0 et 0,01$ à la place de 8,00€
DanielCo
2017-02-17 09:17:25 UTC
Permalink
Raw Message
Bonjour,
Essaie :
# #00.00" €"
Cordialement.
Daniel
Post by Brat'ac
Bonjour,
dans le classeur les zéros ne sont pas affichés dans les cellules,
mais j'aimerais bien que dans les
cellules qui ont un format en euros celle-ci affichent quand même
00,00€
J'ai essayé de créer un format sans résultat
Merci
Brat'ac
2017-02-17 11:46:46 UTC
Permalink
Raw Message
DanielCo avait prétendu :


Merci à vous tous,

comme cela ne fonctionnait pas chez moi (Pourquoi mystère ?)

Je m'en suis sortie comme cela:

Format "Monétaire" dans la cellule et =SI(L6-L7=0;0;) ce qui me donne
-0,00€ , le signe - je comprends pas, mais pas trop gênant !

Bonne journée
MichD
2017-02-17 13:13:12 UTC
Permalink
Raw Message
As-tu pris le temps d'adapter le séparateur décimal dans les propositions que tu as reçues
selon la configuration de ton ordinateur?

MichD
Brat'ac
2017-02-17 14:12:58 UTC
Permalink
Raw Message
Post by MichD
As-tu pris le temps d'adapter le séparateur décimal dans les propositions que
tu as reçues selon la configuration de ton ordinateur?
MichD
Finalement avec =SI(L6-L7=0;0;L6-L7) et comme format pour cette cellule
# ##0,00" €" c'est OK
plus de - devant, comme cela pas besoin de décocher "valeurs zéro" dans
les options si non
j'avais zéro dans toutes les cellules qui par exemple avaient comme
formule
"=SOMMEPROD(SI(ESTERREUR(G54+I54+K54+M54);0;(G54+I54+K54+M54)))"
dont les conditions n'étaient pas bonnes. (je ne voulait afficher le
zéro QUE dans cette cellule)

Merci à tous, et bonne journée.
Brat'ac
2017-02-17 14:12:59 UTC
Permalink
Raw Message
Post by MichD
As-tu pris le temps d'adapter le séparateur décimal dans les propositions que
tu as reçues selon la configuration de ton ordinateur?
MichD
Finalement avec =SI(L6-L7=0;0;L6-L7) et comme format pour cette cellule
# ##0,00" €" c'est OK
plus de - devant, comme cela pas besoin de décocher "valeurs zéro" dans
les options si non
j'avais zéro dans toutes les cellules qui par exemple avaient comme
formule
"=SOMMEPROD(SI(ESTERREUR(G54+I54+K54+M54);0;(G54+I54+K54+M54)))"
dont les conditions n'étaient pas bonnes. (je ne voulait afficher le
zéro QUE dans cette cellule)

Merci à tous, et bonne journée.
Brat'ac
2017-02-17 14:13:42 UTC
Permalink
Raw Message
Brat'ac a pensé très fort :


Désolé pour le doublon
MichD
2017-02-17 21:25:44 UTC
Permalink
Raw Message
Si tu as au moins un caractère qui apparait dans l'une des 4 cellules, alors la fonction somme
s'exécute et 0 peut être un des résultats possibles.

=SI(NBCAR(G54&I54&K54&M54)=0;"";SOMME(G54;I54;K54;M54))

MichD
Brat'ac
2017-02-18 17:23:44 UTC
Permalink
Raw Message
Post by MichD
Si tu as au moins un caractère qui apparait dans l'une des 4 cellules, alors
la fonction somme s'exécute et 0 peut être un des résultats possibles.
=SI(NBCAR(G54&I54&K54&M54)=0;"";SOMME(G54;I54;K54;M54))
MichD
OK merci ,je teste

Loading...