Discussion:
Renvoyer en-tête de colonne du critère 2 en fonction de 2 critères
(trop ancien pour répondre)
FannyZ
2020-04-14 07:25:24 UTC
Permalink
Bonjour,

Me revoilà avec une nouvelle question… Décidemment, mon document me fai
arracher les cheveux !

Je possède un tableau avec en colonne B des numéro de lots, dans les colonne
qui suivent, j'ai les dates de passage sur ligne (l'en tête des colonne
correspond à la machine)
Exemple:
Num de lots Machine1 Machine 2
1A 01/01/20 06/01/20
2A 05/01/20 06/01/20
3A 02/01/20 09/01/20

Dans une seconde feuille, j'ai un listing en colonne B des numeros de lots, e
en colonne C des dates de passage sur ligne.

Exemple:
Num de lots Date de prod
1A 01/01/20
1A 06/01/20
2A 05/01/20
2A 06/01/20
3A 02/01/20
3A 09/01/20

Je souhaiterai ajouter une colonne D, qui indique sur quelle machine le lot X
la date Y passe, sachant qu'un lot ne peut pas passer sur deux machines à l
même date.

Exemple de résultat souhaité:
Num de lots Date de prod Machine
1A 01/01/20 Machine1
1A 06/01/20 Machine2
2A 05/01/20 Machine1
2A 06/01/20 Machine2
3A 02/01/20 Machine1
3A 09/01/20 Machine2

J'imagine que ca va être quelque chose avec une recherche matricielle, mais j
ne m'y connais pas bien…

D'avance merci pour votre aide !
Daniel
2020-04-14 09:54:31 UTC
Permalink
Post by FannyZ
Bonjour,
Me revoilà avec une nouvelle question… Décidemment, mon document me fait
arracher les cheveux !
Je possède un tableau avec en colonne B des numéro de lots, dans les colonnes
qui suivent, j'ai les dates de passage sur ligne (l'en tête des colonnes
correspond à la machine)
Num de lots Machine1 Machine 2
1A 01/01/20 06/01/20
2A 05/01/20 06/01/20
3A 02/01/20 09/01/20
Dans une seconde feuille, j'ai un listing en colonne B des numeros de lots, et
en colonne C des dates de passage sur ligne.
Num de lots Date de prod
1A 01/01/20
1A 06/01/20
2A 05/01/20
2A 06/01/20
3A 02/01/20
3A 09/01/20
Je souhaiterai ajouter une colonne D, qui indique sur quelle machine le lot X à
la date Y passe, sachant qu'un lot ne peut pas passer sur deux machines à la
même date.
Num de lots Date de prod Machine
1A 01/01/20 Machine1
1A 06/01/20 Machine2
2A 05/01/20 Machine1
2A 06/01/20 Machine2
3A 02/01/20 Machine1
3A 09/01/20 Machine2
J'imagine que ca va être quelque chose avec une recherche matricielle, mais je
ne m'y connais pas bien…
D'avance merci pour votre aide !
Bonjour,

En partant du principe d'après l'énoncé que dans la feuille 2 pour 1 lot
de produit, si la date n'est pas dans la colonne de la machine 1 de la
feuille 1... c'est qu'elle est dans la machine 2, ça devrait le faire
avec ça.
Dans la feuille 2 en D2 tu mets :
=SI(C2=RECHERCHEV(B2;Feuil1!$A$2:$C$4;2);"Machine1";"Machine2")

Daniel
fannyz
2020-04-15 07:29:30 UTC
Permalink
Post by FannyZ
Post by FannyZ
Bonjour,
Me revoilà avec une nouvelle question… Décidemment, mon
document me fait
arracher les cheveux !
Je possède un tableau avec en colonne B des numéro de lots, dans les colonnes
qui suivent, j'ai les dates de passage sur ligne (l'en tête des colonnes
correspond à la machine)
Num de lots Machine1 Machine 2
1A 01/01/20 06/01/20
2A 05/01/20 06/01/20
3A 02/01/20 09/01/20
Dans une seconde feuille, j'ai un listing en colonne B des numeros de lots
et
Post by FannyZ
Post by FannyZ
en colonne C des dates de passage sur ligne.
Num de lots Date de prod
1A 01/01/20
1A 06/01/20
2A 05/01/20
2A 06/01/20
3A 02/01/20
3A 09/01/20
Je souhaiterai ajouter une colonne D, qui indique sur quelle machine le lo
X
Post by FannyZ
Post by FannyZ
à
la date Y passe, sachant qu'un lot ne peut pas passer sur deux machines à la
même date.
Num de lots Date de prod Machine
1A 01/01/20 Machine1
1A 06/01/20 Machine2
2A 05/01/20 Machine1
2A 06/01/20 Machine2
3A 02/01/20 Machine1
3A 09/01/20 Machine2
J'imagine que ca va être quelque chose avec une recherche matricielle, mais je
ne m'y connais pas bien…
D'avance merci pour votre aide !
Bonjour,
En partant du principe d'après l'énoncé que dans la
feuille 2 pour 1 lot
de produit, si la date n'est pas dans la colonne de la machine 1 de la
feuille 1... c'est qu'elle est dans la machine 2, ça devrait le faire
avec ça.
=SI(C2=RECHERCHEV(B2;Feuil1!$A$2:$C$4;2);"Machine1";"Machine2")
Daniel
Bonjour Daniel,

C'est super, merci beaucoup!!! Comme j'ai plusieurs machines, j'ai utilisé un
fonction si.conditions et ca marche parfaitement. Je devais changer ma manièr
de raisonner.
Passez une excellente journée!

Loading...