Discussion:
Formule
(trop ancien pour répondre)
Magix
2020-04-15 11:22:28 UTC
Permalink
Bonjour, je souhaiterais soustraire 2 cellule comprenant des formules.
Exemple :
J'ai une cellule H7 avec la formule : =SI(H11="";"";SOMME(F11:F100))
+ une cellule Q7 avec la formule : =SI(Q11="";"";SOMME(O11:O100))

Je voudrais créer une nouvelle cellule A1 avec la formule H7-Q7 en prennen
compte que si la cellule H7 sois vide que celui-ci me calcule donc ZERO-Q7 !

Mais si l'une des deux cellule H7/Q7 et vide il me met #VALEUR! dans la cellul
A1.

Merci
Jc
2020-04-15 12:08:27 UTC
Permalink
Post by Magix
Bonjour, je souhaiterais soustraire 2 cellule comprenant des formules.
J'ai une cellule H7 avec la formule : =SI(H11="";"";SOMME(F11:F100))
+ une cellule Q7 avec la formule : =SI(Q11="";"";SOMME(O11:O100))
Je voudrais créer une nouvelle cellule A1 avec la formule H7-Q7 en prennent
compte que si la cellule H7 sois vide que celui-ci me calcule donc ZERO-Q7 !
Mais si l'une des deux cellule H7/Q7 et vide il me met #VALEUR! dans la
cellule A1.
Merci
Bonjour,
et avec :;
=SIERREUR(H7-Q7;"")
autrement dit si la formule H7-Q7 génère une erreur il faut écrire ""
(donc rien, en fait on peut mettre ce que l'on veut entre les
guillemets), par contre si le calcul est valable il faut inscrire le
résultats.
--
______________________________________________
Jc
FxM
2020-04-15 12:18:53 UTC
Permalink
Post by Magix
Bonjour, je souhaiterais soustraire 2 cellule comprenant des formules.
J'ai une cellule H7 avec la formule : =SI(H11="";"";SOMME(F11:F100))
+ une cellule Q7 avec la formule : =SI(Q11="";"";SOMME(O11:O100))
Je voudrais créer une nouvelle cellule A1 avec la formule H7-Q7 en prennent
compte que si la cellule H7 sois vide que celui-ci me calcule donc ZERO-Q7 !
Mais si l'une des deux cellule H7/Q7 et vide il me met #VALEUR! dans la cellule
A1.
Merci
Bonjour,

Soustraire un texte ("") n'a jamais fonctionné.
A défaut :
=SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0)

Le plus sûr serait de rester dans du numérique en H7 et Q7.
Par exemple via H7 -> somme(F11:F100)
et mise en forme conditionnelle de la police en blanc sur blanc.

Cordialement
FxM
magix
2020-04-15 12:52:48 UTC
Permalink
Post by Magix
Bonjour, je souhaiterais soustraire 2 cellule comprenant des formules.
=SI(H11="";"";SOMME(F11:F100))
=SI(Q11="";"";SOMME(O11:O100))
Je voudrais créer une nouvelle cellule A1 avec la formule H7-Q7 en
prennent compte que si la cellule H7 sois vide que celui-ci me calcule donc
ZERO-Q7 !
Mais si l'une des deux cellule H7/Q7 et vide il me met #VALEUR! dans l
cellule
Post by Magix
A1.
Merci
Merci à JC mais effectivement la formule de FxM fonctionne mieux.

Merci pour votre aide, mais a présent j'aimerais que A1 avec la formule qu
vient de me cité Fxm puisse n'avoir aucune valeur si H7 et Q7 n'ont pas d
valeur.

Si aucune des deux n'a de valeur la cellule A1 m'affiche 0, et j'aimerai
evité.

Cdlt
Jc
2020-04-15 13:35:38 UTC
Permalink
Post by magix
Merci à JC mais effectivement la formule de FxM fonctionne mieux.
Merci pour votre aide, mais a présent j'aimerais que A1 avec la formule que
vient de me cité Fxm puisse n'avoir aucune valeur si H7 et Q7 n'ont pas de
valeur.
Si aucune des deux n'a de valeur la cellule A1 m'affiche 0, et j'aimerais
evité.
Cdlt
Re,
Tu as essayé la formule sierreur ?
Il me semble qu'elle fait ce que tu demandes ?
--
______________________________________________
Jc
magix
2020-04-15 14:01:48 UTC
Permalink
Post by Jc
Post by magix
Merci à JC mais effectivement la formule de FxM fonctionne mieux.
Merci pour votre aide, mais a présent j'aimerais que A1 avec la formule que
vient de me cité Fxm puisse n'avoir aucune valeur si H7 et Q7 n'ont pas de
valeur.
Si aucune des deux n'a de valeur la cellule A1 m'affiche 0, et j'aimerais
evité.
Cdlt
Re,
Tu as essayé la formule sierreur ?
Il me semble qu'elle fait ce que tu demandes ?
--
______________________________________________
Jc
Je n'arrive malheureusement pas :/ j'ai encore beaucoup du mal avec les formule
:/
MichD
2020-04-15 14:15:52 UTC
Permalink
Bonjour,

Essaie comme ceci :

=SI(ESTVIDE( H7);0-Q7;H7-Q7)

MichD
magix
2020-04-15 14:29:51 UTC
Permalink
Post by Magix
Bonjour,
=SI(ESTVIDE( H7);0-Q7;H7-Q7)
MichD
Perdu :/
magix
2020-04-15 14:45:45 UTC
Permalink
Post by Magix
Bonjour,
=SI(ESTVIDE( H7);0-Q7;H7-Q7)
MichD
Je refait ma demande pour être sur de ne pas se tromper :

Cellule H7 : =SI(H11="";"";SOMME(F11:F100))
Cellule Q7 : =SI(Q11="";"";SOMME(O11:O100))

Cellule A1 : =SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0)

Voila mais si la cellule H7 et Q7 ne contient pas de valeur, la cellule A
Affiche 0

J'ai trouver cette formule
=SI(H7="";"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))

Mais sa ne prend en considération que H7 et non Q7 je ne sais pas comment fair
genre : Que A1 = VIDE Sauf si H7 ou Q7 contient une valeur alors formule.
MichD
2020-04-15 15:27:00 UTC
Permalink
=SI(ET(ESTVIDE(H7);ESTVIDE(Q7));"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))

MichD
magix
2020-04-15 15:47:42 UTC
Permalink
Post by MichD
=SI(ET(ESTVIDE(H7);ESTVIDE(Q7));"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))
MichD
Merci beaucoup pour ton aide, mais helas cela m'affiche toujours un 0
Daniel
2020-04-15 16:53:08 UTC
Permalink
Post by magix
Post by MichD
=SI(ET(ESTVIDE(H7);ESTVIDE(Q7));"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))
MichD
Merci beaucoup pour ton aide, mais helas cela m'affiche toujours un 0
Bonjour,

Il y a aussi dans la configuration d'excel (à voir selon la version où
cela est) : Ne pas afficher les valeur nulle... et là plus de 0 affichés
seuls dans les cellules

Daniel
Michel__D
2020-04-15 15:34:21 UTC
Permalink
Bonjour,
Post by magix
Post by Magix
Bonjour,
=SI(ESTVIDE( H7);0-Q7;H7-Q7)
MichD
Cellule H7 : =SI(H11="";"";SOMME(F11:F100))
Cellule Q7 : =SI(Q11="";"";SOMME(O11:O100))
Cellule A1 : =SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0)
Voila mais si la cellule H7 et Q7 ne contient pas de valeur, la cellule A1
Affiche 0
=SI(H7="";"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))
Mais sa ne prend en considération que H7 et non Q7 je ne sais pas comment faire
genre : Que A1 = VIDE Sauf si H7 ou Q7 contient une valeur alors formule.
Voici une solution possible.

=SI(N(H7)-N(Q7)=0;"";N(H7)-N(Q7))

Et non je ne suis pas MichD
magix
2020-04-15 15:59:28 UTC
Permalink
Post by Magix
Bonjour,
Post by magix
Post by Magix
Bonjour,
=SI(ESTVIDE( H7);0-Q7;H7-Q7)
MichD
Cellule H7 : =SI(H11="";"";SOMME(F11:F100))
Cellule Q7 : =SI(Q11="";"";SOMME(O11:O100))
Cellule A1 : =SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0)
Voila mais si la cellule H7 et Q7 ne contient pas de valeur, la cellule A1
Affiche 0
=SI(H7="";"";SI(ESTNUM(H7);H7;0)-SI(ESTNUM(Q7);Q7;0))
Mais sa ne prend en considération que H7 et non Q7 je ne sais pas comment faire
genre : Que A1 = VIDE Sauf si H7 ou Q7 contient une valeur alors formule.
Voici une solution possible.
=SI(N(H7)-N(Q7)=0;"";N(H7)-N(Q7))
Et non je ne suis pas MichD
Effectivement sa fonctionne aussi :)

Merci beaucoup :)
MichD
2020-04-15 16:20:28 UTC
Permalink
Pour masquer le 0 dans une cellule, un format de cellule est efficace,

comme celui-ci : Format de la cellule A1 : Format personnalisé : ;;;;
et le 0 n'est plus visible!

MichD
MichD
2020-04-15 17:57:46 UTC
Permalink
Le format de cellule personnalisée est plutôt :
Standard;Standard;;

;-))

MichD

Loading...